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INTRODUCTION TO SEISSOUND VIDEO PRODUCTS
ăFJODSFBTFEQPQVMBSJUZPG:PV5VCFWJEFPTIBTDIBOHFEUIF
format of how information is distributed and assimilated, highlighting the importance of including auditory information in
videos. Videos that include sound also permeate the research
community, as evidenced by their recent increase within online
supplements to journal articles. Tapping into this new approach
PGJOGPSNBUJPOFYDIBOHF XFBSFDSFBUJOHWJEFPTPGTFJTNJDEBUB
that augment visual imagery with auditory counterparts. We
term these “SeisSound” video products (Figure 1). We find the
SJDIOFTT BOE DPNQMFYJUJFT PG TFJTNJD EBUB DBO NPSF FBTJMZ CF
appreciated using these SeisSound products than using just the
individual visual or the auditory components independently.
Seismology includes the study of a large number of processes that affect the spectral content of a seismogram including
TQBUJBMFYUFOU EVSBUJPO BOEEJSFDUJWJUZPGBTPVSDFQBUIFĈFDUT
TVDIBTBUUFOVBUJPO OFBSTVSGBDFHFPMPHZ BOECBTJOSFTPOBODF
and the differences between abrupt tectonic earthquakes and
unusual sources such as volcanic and non-volcanic tremor.
With training, we can learn to discern the seismic signatures
of these different processes, which can be inferred from the
TQFDUSBM DPOUFOU GSPN UJNF TFSJFT  TQFDUSB  BOE TQFDUSPHSBNT
however, subtle differences in these signals can be difficult to
DPOWFZFBTJMZUPBMFTTFYQFSJFODFEBVEJFODF
A number of our senses include the ability to act as spectral analyzers. In the audible sound range we hear pitch, in the
visible light range we see color, and in the low- and sub-audible range we can feel the difference between sudden and slow
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motions using our senses of motion and touch. For most people, the concepts of high or low pitch (frequency) and volume
(amplitude) are innate. When we listen to a symphony orchestra, we can pick out the sound of individual instruments and
decipher the unique spectral content of their tones even though
a hundred musicians are playing simultaneously. Similarly, we
can teach people how to use these innate abilities to understand seismology by having them listen to the frequency conUFOUXJUIJOBTFJTNPHSBN$PNCJOJOHWJTVBMJOGPSNBUJPOXJUI
the auditory can increase the connection between the heard
pitch and the visually observed frequency content within
TFJTNPHSBNT BOE TQFDUSPHSBNT TFF FYBNQMF JO DPNQBOJPO
paper Peng et al. 2012, this issue, in the EduQuakes column).
*OUSPEVDJOH UPQJDT JO TFJTNPMPHZ JO UIJT XBZ DBO FYUFOE PVS
ability to communicate effectively with diverse audiences who
have a variety of learning styles and levels.
The audible frequency range for humans is roughly 20
)[mL)[ XIJDIJTBCPVUUXPUPUISFFPSEFSTPGNBHOJUVEF
(or seven to ten octaves) higher than the frequency content for
most recorded earthquake signals. To bring the sub-audible
frequency content of earthquake seismograms into the audible
range, the seismic data need to be shifted to a higher pitch. To
accomplish this, the simplest and purest method is to time
compress the seismogram (FH )BZXBSE%PNCPJT
Dombois and Eckel 2011) by increasing the playback speed relative to the recording rate. Time compression also allows us to
play back a long record in a reasonable amount of time during a
lecture or demonstration.
Time compression as a method to convert seismic data to
BVEJCMFTPVOEJTBOFYBNQMFPGiBVEJđDBUJPO uBTJNQMFTVCTFU
of the general field of “sonification,” which can involve more
DPNQMFYSFQSFTFOUBUJPOPGEBUBUISPVHIUSBOTGPSNBUJPOTVTJOH
various sound attributes (FH pitch, volume, and timbre). Early
FYQFSJNFOUT XJUI BVEJđDBUJPO JO TFJTNPMPHZ CFHBO XJUI UIF
advent of magnetic tape recording, which allowed playback
at speeds higher than the recorded speed. One of the earliest
FYBNQMFTPGUSBOTGPSNJOHTFJTNJDEBUBJOUPBVEJCMFTPVOETXBT
BSFDPSEJOHCZ#FOJPĈ  XIJDIJODMVEFTWBSJPVTSFHJPOBM
and teleseismic earthquakes recorded on an early tape sysUFNBU$BMUFDIT1BTBEFOBTFJTNJDTUBUJPO5JNFDPNQSFTTJPO
using magnetic tape recording also was tested successfully as a
NFUIPE UP EJTDSJNJOBUF CFUXFFO FBSUIRVBLFT BOE FYQMPTJPOT
4QFFUI  'SBOUUJ BOE -FWFSFBVMU   .VJSIFBE BOE
4JNQTPO  VTFEBOVMUSBTMPXTQFFE JODITFD EJSFDU
recording tape system to record a variety of earthquakes and
FYQMPTJPOT JO "VTUSBMJB BOE JODPSQPSBUFE UJNFTIJĕFE BVEJP
processing in their analysis. Some of these events were used as
part of the “Murmurs of Earth” collection for the “Interstellar
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! Figure 1. Snapshot from a sample SeisSound video product. Shown is the transverse component of data from the 2002 magnitude 7.8
Denali earthquake in Alaska, recorded at station RDM in southern California (distance of ~4,000 km). The seismogram trace changes from
light to dark as a time indicator progression line (vertical pink line) moves from left to right in the video. Original data (top). Data bandpass
filtered 2–8 Hz. (middle). Spectrogram (bottom). Note the locally triggered tremors at 1,000–1,400 s that correspond to the arrival of the
large amplitude surface waves (Gomberg et al. 2008; Chao et al. 2012). To remove any high-frequency artifacts introduced from using a
short time window of data, we applied a 0.5 Hz high-pass filter to the data before computing the spectrogram (Peng et al. 2011).

3FDPSEu MBVODIFE PO /"4"T 7PZBHFS TQBDFDSBĕ JO 
(Sagan et al.     8JUI UIF XJEFTQSFBE VTF PG EJHJUBM
recording in seismology, it is now possible to convert seismic
waveforms to standard audio formats and apply simple filtering and time-compression techniques using widely available
audio processing software. These types of auditory presentations of seismic data are now commonly used for educational
purposes (FH  .JDIBFM  4JNQTPO  .JDIBFM  
and have recently regained popularity to highlight differences
between typical earthquake recordings and tremor-like signals
(Simpson et al.'JTIFSet al. 2010).

METHOD
Overview
The SeisSound visual component includes the seismogram and
corresponding spectrogram, presented in movie format indicating how the data evolve with time. An auditory sound file

(WAVE format) of the data that are time compressed accompanies the visual information so the frequency content of the
TFJTNPHSBNDBOCFFBTJMZIFBSE$PNCJOJOHBVEJPBOEWJTVBM
JOGPSNBUJPO BMMPXT UIF VTFS UP CPUI IFBS BOE TFF DPNQMFYJties in the frequency-time distribution of the seismogram that
are often otherwise hidden in large-amplitude signals. These
SeisSound video products provide a unique way to watch and
listen to the vibration of the Earth, and help introduce more
advanced topics in seismology.
Our computer codes are written with MATLAB and
are freely available for use (see the electronic supplement’s
MATLAB codes and data bundle). These MATLAB codes
produce an audio file and a sequence of static image files. The
audio track is produced using the MATLAB function XBWFXSJUF, which allows a scaling factor to be applied to speed up or
slow down the playback speed. It typically takes only a few minutes for the code to process a standard seismogram. A bundled
file that contains the MATLAB programs and sample data is
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Audio

! Figure 2. Suggested directory structure. The “Images” and
“Audio” subdirectories will be automatically added and filled by
the SeisSound.m MATLAB program.

available from our electronic supplement (MATLAB codes
and data bundle). Figure 2 shows the recommended directory
structure for the codes and data. A list of the MATLAB programs and a description of the parameters used to call the main
program are listed in Tables 1 and 2.
For each seismogram, the MATLAB code reads seismic
EBUB JO 4FJTNJD "OBMZTJT $PEF 4"$  GPSNBU (PMETUFJO et
al.  (PMETUFJO BOE 4OPLF   BOE HFOFSBUFT B TPVOE
8"7&đMFBOEUIFJNBHFđMFT _m TIPXJOHUIFFWPMVtion of the seismogram and spectrogram data with time. We
use the software QuickTimePro to concatenate the images into
a video and add the corresponding audio file in sync with the
video to create a SeisSound video. The final SeisSound video
đMFTJ[F UZQJDBMMZ_m.# JTEFQFOEFOUPOUIFSFTPMVUJPO
and size of the images and the total number of frames in the
video. In addition to the video product, we also include a standalone MATLAB code sac2wav.m to directly convert seismic
EBUBJO4"$GPSNBUUPBOBVEJP8"7&đMFăF*ODPSQPSBUFE
Research Institutions for Seismology (IRIS) Data Management
4ZTUFN %.4 BMTPQSPWJEFTB8FCTFSWJDFGPSFYUSBDUJOHXBWFforms from the archive and converting them to WAVE format
(http://www.iris.edu/ws/timeseries/).
Steps Required to Create SeisSound Products
There are two main steps required to create a SeisSound video.
The first step requires running the SeisSound.m MATLAB
code to produce an audio WAVE file and the sequence of
images. As the code runs, it will display images of the data in
three panels. The top panel shows the original seismogram, the
middle panel a filtered version of the data, and the bottom a
spectrogram of the data (FH  see Figure 1). If you encounter
an error message indicating a missing variable or function,
check that you have all of the required routines (see Table 1)
and that the codes and data are stored in the proper location
in the directory structure (Figure 2). If the code runs successfully, a notification of “Render Finished” will be issued at the
MATLAB command window and two new subdirectories
named “Audio” and “Images” will be added appropriately (FH
see Figure 2). In the second step, the audio and image files are
NFSHFEUPQSPEVDFB4FJT4PVOEWJEFP 'JHVSFBOE5BCMF 

TABLE 1
Description of MATLAB routines used to create the
sound and image files for SeisSound video products. The
electronic supplement MATLAB codes and data bundle
contains a bundle of these codes and sample data.
Filename
eqfiltfilt.m
fget_sac.m
linex.m
main_tremor.m
sac.m
sachdr.m
SeisSound.m
sac2wav.m

Purpose
perform a Butterworth filter
read sac formatted data into MATLAB
draw a vertical line at a specified position
main program that calls SeisSound
read a single SAC data file
read the header file of SAC formatted data
[Main program] generated images and an
audio wave file
create an audio wave file from SAC
formatted data

It is relatively straightforward to process seismic waveGPSNEBUBVTJOH4FJT4PVOE$VSSFOUMZ UIFJOQVUEBUBNVTUCF
JO4"$GPSNBUBOETUBOEBSE4"$SPVUJOFTPSUIF*3*4%BUB
.BOBHFNFOU$FOUFS %.$ UJNFTFSJFT8FCTFSWJDF (http://
www.iris.edu/ws/timeseries) can be used to preprocess (FH filter and scale) the data. Station and waveform metadata (FH
station code, start time, sample rate, etc.) are transferred to the
4FJT4PVOEQSPHSBNWJBUIF4"$IFBEFSBOEBEEJUJPOBMJOGPSmation required to create the SeisSound products is provided
via parameters in the calling function as described in Table 2.

SAMPLE SEISSOUND VIDEO PRODUCTS
"OBTTPSUNFOUPG4FJT4PVOEFYBNQMFT TFMFDUFEUPEFNPOTUSBUF
differences in the frequency and temporal characteristics of different seismic signals, can be found in our electronic supplement.
Because of the wide dynamic range, the sound can be better
appreciated on a computer with good speakers or with earbuds
to hear the full effect of the lower frequencies. The amplitude of
the low frequencies can sometimes be large, so it is best to keep
the volume initially low to avoid damaging the speakers or, if
you are using earbuds, your ears. With these SeisSound products, students can begin to decipher and understand complicated earthquake physics and earthquake triggering processes.
Notable signatures in the videos can be indicative of certain
TFJTNJDQSPDFTTFT'PSFYBNQMF NVMUJQMFWFSUJDBMTUSFBLTPGSFEJO
the spectrogram, corresponding to popping sounds that begin
at a fast rate and then ebb (FH .BHOJUVEF4BNPB*TMBOET
3FHJPO   4FQUFNCFS   65$ TUBUJPO "'* 
AFI_aftershock_movie60FPS.mov) are characteristic of a mainshock/aftershock sequence (FH Peng et al. ,JMCet
al. "VOJGPSNEJTUSJCVUJPOPGWFSUJDBMTUSFBLTJOUIFTQFDtrogram accompanied by a repetitive pop-pop-pop tempo sound
(FH %SVNCFBUFBSUIRVBLFTXBSNTEVSJOHUIF.PVOU4U
)FMFOT FSVQUJPO MtStHelen_Drumbeat.mov) is a characteristic
of “drum beat” earthquake swarms during volcanic eruptions
(Iverson et al. 2006). Another similar, yet distinctly different,
signature is that of triggered deep non-volcanic tremor that
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TABLE 2
Parameters required to call the SeisSound.m MATLAB function. The number in column 1 indicates the position of this
parameter in the function call list. The formal function call uses this format: function SeisSound(inputdata, directory, titleit,
starttime, endtime, filt_low, filt_high, ff_max, units, dtype, speed_factor, ColorBar_Upper_Limit, ColorBar_Lower_Limit,
FramesPerSecond). An example of how to call the program can be found in “main_tremor.m.”
Parameter Name

Description

Default

1 inputdata
2 directory

Data file name
BK.PKD.HHT.SAC
Name of the folder where the data resides and where the
Denali_2002_at_Parkfield
code generated images and audio directories will be added
3 titleit
Title to be used on all generated images
Data from [name of input data file]
4 starttime
Seismogram start time in seconds, use -999 to use the start
–999
time of the data
5 endtime
Seismogram end time in seconds, use -999 to use the end time
–999
of the data
6 filt_low
Lower band limit if data filtering is requested (for low-pass
–999
only or no filter use -999)
7 filt_high
High band limit if data filtering is requested (for high-pass only
–999
or no filter use -999)
8 ff_max
Enforced maximum frequency for the spectrogram (use -999
–999
to display all available frequencies)
9 units
Units for seismogram y-axis label (e.g., cm/s or cm/s/s). Use
–999
-999 to display no units.
10 dtype
Data type (e.g., displacement, velocity, or acceleration). Use
–999
-999 to default to data type specified in the SAC file (i.e., hdr.
descrip.idep).
11 speed_factor
Audio file scale factor
100
12 ColorBar_Upper_Limit Upper limit of the color bar of the spectrogram
0
13 ColorBar_Lower_Limit Lower limit of the color bar of the spectrogram
–80
14 FramesPerSecond
The frame per second rate you plan to use in your final
–999
SeisSound movie; this parameter will determine the number of
images generated. Use -999 to let the program select the rate
for you.

typically occurs during the passage of the surface waves (FH
Peng et al.  XIJDINBOJGFTUTBTWFSUJDBMTUSFBLTJO
the spectrogram during the surface wave portion of the seismic
wavetrain accompanied by a relatively short-lived rat-a-tat-tat
sound as from a snare drum (FH Triggered tremor in Parkfield,
$BMJGPSOJB GSPNUIF.X%FOBMJ "MBTLB FBSUIRVBLF
Denali_Triggered_Tremor.mov  ăF DPEFT BOE FYBNQMF EBUB JO
the electronic supplement bundled file are set up to create this
FYBNQMFVTJOHUIF."5-"#TDSJQUiNBJO@USFNPSNu

AUDIENCE AND USES FOR SEISSOUND VIDEO
PRODUCTS
8FIBWFVTFE4FJT4PVOEWJEFPQSPEVDUTJO_FEVDBUJPOBMTFUtings and public lectures ranging from teaching kindergarteners to educating more advanced audiences, including graduate
TUVEFOUTBOEFYQFSJFODFETFJTNPMPHJTUTăF4FJT4PVOEJNBHFT
and sounds immediately captivate audiences regardless of their
BHF BOE FYQFSUJTF  BOE UIF DPNQMFYJUZ PG UIF NFTTBHF DBO CF
adjusted for each group. The innovative combination of auditory and visual information is particularly useful for introduc-

ing seismic data to beginning researchers, including upper-level
undergraduate and first-year graduate students in introductory
geophysics or seismology courses.
SeisSound videos can be used to highlight differences in
the amplitude, frequency, and duration of P and S and surface waves and to teach how to discriminate between seismic
signatures of teleseismic and local earthquakes. For the more
BEWBODFEBVEJFODFT 4FJT4PVOEQSPEVDUTDBOCFVTFEUPFYQMPSF
EFUBJMTPGUIFTQFDUSBMDPOUFOUJOTFJTNPHSBNT$PODFQUTUIBU
can be more easily discussed and investigated by incorporating sound include: categorizing seismic wave attenuation with
distance from the source, discriminating between large and
small earthquakes, identifying aftershock rates, and recognizing site effects including reverberation in basins (FH Benioff
.JDIBFM4JNQTPOet al.'JTIFSet al. 2010).
SeisSound products can also be useful in discriminating complicated seismic signals from multiple sources, such as aftershocks within the coda of large earthquakes (FH Peng et al.
 ,JMCet al. SFNPUFUSJHHFSJOHPGFBSUIRVBLFT
(Hill et al. BOEUSFNPS FH Peng et al.  
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FUTURE DEVELOPMENT
8F XJMM CF XPSLJOH XJUI UIF *3*4 %.$ UP DSFBUF BOE EJTtribute select SeisSound products through the IRIS product
repository. To accomplish this we plan to fully automate the
process of creating SeisSound video products by replacing the
use of QuickTimePro with the freeware alternatives, which
will allow batch mode processing. We will also design the end
products to include associated metadata information such as
recording station (station name and component), earthquake
parameters (time, latitude, longitude, depth, magnitude), and
signature of interest in the waveform (FH aftershocks, tremor,
volcanic drumbeats).
The design of SeisSound is modular enough to easily
incorporate future enhancements. These might include but are
not limited to: 1) An audio-video Webservice, similar to the
IRIS time series Webservice (http://www.iris.edu/ws/timeseries/), which would allow users to either specify data at the
*3*4%.$UIBUUIFZXBOUUPQSPDFTTPSUPVQMPBEUIFJSPXO
EBUB "DVTUPNJ[BCMFEJTQMBZUIBUBMMPXTUIFTQFDUSPHSBNT
to be displayed in log-amplitude, or shows a series of the same
TFJTNPHSBNXJUIEJĈFSFOUđMUFSTBQQMJFE "TFSJFTPGEJĈFSent seismograms played in sequence, presented either with true
relative amplitude (volume represents differences in amplitude)
PSOPSNBMJ[FEBNQMJUVEF FBDISFDPSEIBTUIFTBNFNBYJNVN
MFWFM  FNQIBTJ[JOH UIF EJĈFSFODFT JO QJUDI    "ĕFSTIPDL
USFNPS MPDBUJPO BOJNBUJPOT $PODVSSFOU XJUI UIF UFNQPSBM
evolution of the sound file and animated seismic data display,
a map or cross-section of aftershock/tremor locations could be
included where aftershocks/tremors in the current time window are marked as red or other colors, and then fade as time
QSPHSFTTFT TFFFYBNQMFJODPNQBOJPOQBQFS1FOHet al. 2012,
this issue, in the EduQuakes column).
Although here we report on a relatively simple product that
is primarily geared for use in educational settings, the concepts
EFNPOTUSBUFECZ4FJT4PVOEDBOCFFYQBOEFEJOUPNPSFTPQIJTticated research applications. A more advanced, and perhaps

Seismic Data

Surface Wave
Surface Wave
Surface Wave
C.-D!E.FF%#!*%GH
C.-D!E.FF%#!*%GH
C.-D!E.FF%#!*%GH

Sound !WAVE" file
Image Sequence

QuickTime Pro

! Figure 3. Flow chart of the current construction of the
SeisSound video products. Future plans include replacing
QuickTimePro (indicated with the “Q”) with a command line
freeware alternative such as ffmpeg or mencoder.

interactive, tool could include features such as zooming, filtering, and three-component rotation transformations. With these
types of options available, the user could more efficiently search
large quantities of seismic data for complicated and/or small
nuances such as aftershock distribution characteristics, remotely
USJHHFSFEFBSUIRVBLFT BOEUSFNPS8FFYQFDUJUXJMMCFFBTJFS

TABLE 3
Using the QuickTimePro software, the following steps can be used to generate a final SeisSound product from a sound file
(e.g., soundfile.wav) stored in a directory called Audio and sequence of images files (e.g., image_100.jpg) stored in a directory
called Images.
Step Number Description
1
2
3
4
5
6
7

Open QuickTime Pro (http://www.apple.com/quicktime/extending /)
Use the top pull-down menu: File -> Open Image Sequence -> choose the first image Images/image_100.jpg,
then choose 6 frames per second (or a parameter consistent with that used generating the images with
SeisSound.m). An animation without sound is generated.
Use the top pull-down menu: File -> Open -> choose Audio/soundfile.wav.
Click Edit -> select all -> copy to copy the audio file into memory.
To add sound, first select the newly created video, and then use the pull-down menu Edit -> Add to Selection
and Scale. This will add sound and scale its duration to the length of the current movie.
To save the final product use the pull-down menus File -> Export -> Choose “Export Movie to QuickTime
Movie” and save the final movie.
You can preview the final SeisSound product using any viewer such as QuickTime, QuickTimePro, RealPlayer,
or VLC.
Seismological Research Letters Volume 83, Number 2 March/April 2012 285

to detect these key features using combined audio/visual techniques than with traditional or automated processing.
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